GB/T 34998-2026 移动终端浏览器技术要求

文档天下 标准评论2阅读模式

前言

本文件按照 GB/T 1.1—2020《标准化工作导则 第1部分:标准化文件的结构和起草规则》的规定起草。

本文件代替 GB/T 34998—2017《移动终端浏览器软件技术要求 》,与 GB/T 34998—2017相比,除了结构调整和编辑性改动外,主要技术变化如下:

a) 增加了参考框架,包括运行环境适配、渲染、浏览、定制开发和安全共五部分内容(见第5章);

b) 删除了运行环境要求(2017年版的第5章),增加了运行环境适配,在多端兼容和版本升级方面给出了相关要求(见第6章);

c) 更改了协议要求(见第7章,2017年版的第6章);

d) 删除了流量统计(见2017年版的7.3.3);

e) 删除了并发处理功能(见2017年版的7.13);

f) 删除了响应网页中的通信协议的处理(见2017年版的7.14);

g) 增加了适应屏幕中对折叠屏、挖孔屏的适配兼容和分屏协同(见8.1.1.1);

h) 增加了无障碍访问(见8.1.3.4.5);

i) 增加了低功耗(见8.3.3);

j) 更改了浏览、定制开发(见第8章、第9章,2017年版的第7章、第8章);

k) 增加了内核定制、人工智能增强(见9.2、9.3);

l) 增加了安全要求(见第10章)。

请注意本文件的某些内容可能涉及专利。本文件的发布机构不承担识别专利的责任。

本文件由全国信息技术标准化技术委员会(SAC/TC 28)提出并归口。

本文件起草单位:中国电子技术标准化研究院、北京奇虎科技有限公司、北京小米移动软件有限公司、奇安信网神信息技术(北京)股份有限公司、福州启云信息技术有限公司、长扬科技(北京)股份有限公司。

本文件主要起草人:方春燕、刘书玲、赵坤、史原杰、杨磊、李良杰、赵小平、赵华、陈迎、张健文、周彬、田亮、蔡佩宸。

本文件及其所代替文件的历次版本发布情况为:

2017年首次发布 GB/T 34998—2017;

本次为第一次修订。

1 范围

本文件确立了移动终端浏览器的参考框架,规定了移动终端浏览器的运行环境适配、渲染、浏览、定制开发和安全等要求。

本文件适用于移动终端浏览器的开发、测试和应用。

2 规范性引用文件

下列文件中的内容通过文中的规范性引用而构成本文件必不可少的条款。其中,注日期的引用文件,仅该日期对应的版本适用于本文件;不注日期的引用文件,其最新版本(包括所有的修改单)适用于本文件。

GB/T 13000 信息技术 通用编码字符集(UCS)

GB 18030 信息技术 中文编码字符集

GB/T 33190 电子文件存储与交换格式 版式文档

GB/T 44445 智能移动终端未成年人保护通用规范

GB/T 44720 电子文件存储与交换格式 流式文档

GB 45438 网络安全技术 人工智能生成合成内容标识方法

GB/T 46071 数据安全技术 数据安全和个人信息保护社会责任指南

3 术语和定义

下列术语和定义适用于本文件。

3.1 浏览器 browser

能显示并响应服务器端网页文档和资源的内容,并可让用户与这些文档和资源进行交互的一种软件。

3.2 缓存 cache

响应服务端消息、资源的存储库

注:用于减少未来等效请求的响应时间和网络带宽消耗。

3.3 渲染 rendering

解析网页样式和脚本等网络资源,构建用户可视化界面,并响应用户交互操作的过程。

4 缩略语

下列缩略语适用于本文件。

API:应用程序编程接口(Application Programming Interface)

BMP:位图(BitMaP)

CSS:层叠样式表(Cascading Style Sheets)

DOM:文档对象模型(Document Object Model)

DV:域名验证(Domain Validated)

EV:扩展验证(Extended Validation)

GIF:图形交换格式(Graphics Interchange Format)

GPU:图形处理器(Graphics Processing Unit)

HTML:超文本置标语言(HyperText Markup Language)

HTTP:超文本传输协议(HyperText Transfer Protocol)

HTTPS:超文本安全传输协议(HyperText Transfer Protocol Secure)

I/O:输入/输出(Input/Output)

JPEG:联合图像专家组(Joint Photographic Experts Group)

JS:JavaScript(JavaScript)

MP3:动态影像专家压缩标准音频层面3(Moving Picture experts group audio layerⅢ)

MP4:动态影像专家组四(Moving Picture Experts Group-4)

OFD:开放版式文档(Open Fixed-layout Document)

OV:组织验证(Organization Validated)

PNG:可移植网络图像(Portable Network Graphics)

SVG:可缩放矢量图形(Scalable Vector Graphics)

TLS:传输层安全(Transport Layer Security)

UOF:统一办公文档格式(Uniform Office document Format)

URI:统一资源标识符(Uniform Resource Identifier)

URL:统一资源定位符(Uniform Resource Locator)

WAV:波形音频格式(Waveform Audio Format)

WTLS:无线安全传输层(Wireless Transport Layer Security)

XHTML:可扩展超文本置标语言(eXtensible HyperText Markup Language)

XML:可扩展置标语言(eXtensible Markup Language)

3GP:第三代合作伙伴计划文件格式(3rd Generation Partnership project file format)

5 参考框架

移动终端浏览器的参考框架见图1。

GB/T 34998-2026 移动终端浏览器技术要求
图1 参考框架

移动终端浏览器参考框架如下。

a) 运行环境适配:包括多端兼容、版本升级。

b) 渲染:包括协议解析和网页解析两个部分,其中协议解析包括网络协议、资源标识、用户代理Cookie和缓存;网页解析包括置标语言、脚本语言、编码字符集、音视频、图形图像和文档。

c) 浏览:包括界面、用户数据和配置管理三个部分,其中配置管理包括参数与权限、网络设置和低功耗;用户数据包括书签、上传、下载、访问记录和用户账号管理;界面包括界面管理、导航、标签页和搜索。

d) 定制开发:包括网页扩展、内核定制和人工智能增强,其中网页扩展包括信息查看和页面扩展;人工智能增强包括部署、模型接入、智能交互、页面智能处理和文件智能处理。

e) 安全:包括密码算法、数字证书、数据安全、网页安全、内核安全和安全升级。

6 运行环境适配

6.1 多端兼容

移动终端浏览器:

a) 应能运行在其声明适配的移动终端操作系统与硬件架构上;

b) 运行在不同操作系统和版本时,宜保持渲染的一致性。

6.2 版本升级

移动终端浏览器进行版本升级时:

a) 发现新版本时应给出升级提示,用户可手动操作版本升级;

b) 升级前后,用户设置和用户数据应保持一致;

c) 升级失败应回滚至前一个版本;

d) 宜不依赖于操作系统,自主升级。

7 渲染

7.1 协议解析

7.1.1 网络协议

移动终端浏览器按以下网络协议进行通信:

a) HTTP/1.1;

b) HTTP 2;

c) HTTP 3;

d) TLS 1.3;

e) WTLS ClassⅠ;

f) WebSocket。

7.1.2 资源标识

移动终端浏览器识别和解析 URI,并访问其标识的资源。移动终端浏览器识别和解析的 URI前缀如下。

a) HTTP URL:“http:”和“https:”。

b) 电话号码:“tel:”和“wtai:”。

c) 邮件地址:“mailto:”。

d) 本地文件:“file:”。

7.1.3 用户代理

移动终端浏览器宜识别并处理用户代理,通用格式的表达式如下:

Core(OSN_OSV;LANG;MODEL;SCNW*SCNH)BRSN/BRSV

其中:

a) Core表示浏览器内核名称;

b) OSN_OSV 表示操作系统名称和版本,可选;

c) LANG 表示文种标识,可选;

d) MODEL 表示设备型号,由制造商名称和移动通信终端型号组成,两者之间用“-”或“/”连接,可选;

e) SCNWSCNH 表示屏幕宽和高的分辨率,之间用“”分隔,可选;

f) BRSN/BRSV 表示浏览器名称和版本号。

注:用户代理格式见IETF RFC 9110。

7.1.4 Cookie

移动终端浏览器宜提供 Cookie处理,用于存储和传递会话或用户标识信息。

注:Cookie状态管理机制见IETF RFC 6265。

7.1.5 缓存

移动终端浏览器能缓存数据。

a) 符合IETF RFC 7234。

b) 内存缓存:

1) 在内存中共享同一 URL的图形图像资源,降低内存消耗;

2) 宜采用内存池,减少内存碎片。

c) 存储缓存:

1) 缓存图形图像、CSS文件和网页等资源;

2) 使用淘汰策略清理过期资源。

7.2 网页解析

7.2.1 置标语言

移动终端浏览器能解析以下置标语言:

a) HTML 4.01 Strict;

b) HTML 5;

c) XHTML Basic 1.1;

d) XHTML Mobile profile 1.2;

e) XML 1.0和 XML Namespaces;

f) ATOM 1.0;

g) CSS 2.2;

h) CSS 3。

7.2.2 脚本语言

移动终端浏览器能解析 HTML网页,构建并管理 DOM 树,同步构建渲染树。移动终端浏览器应解析以下脚本语言:

a) ECMA-262;

b) XMLHttpRequest(AJAX);

c) DOM Level 2。

7.2.3 编码字符集

移动终端浏览器应能识别并解析 GB 18030编码字符集的汉字部分,并与 GB/T 13000相应部分建立映射关系。

7.2.4 音视频

7.2.4.1 音视频格式

移动终端浏览器应通过自身或调用音视频解析程序解析以下音视频格式的文件:

a) MP3;

b) 3GP;

c) MP4;

d) WAV。

7.2.4.2 音视频编码

移动终端浏览器宜通过自身或调用音视频解析程序解析音视频文件:

a) 符合 GB/T 33475.2编码的视频;

b) 符合 GB/T 33475.3编码的音频。

7.2.5 图形图像

移动终端浏览器应通过自身或调用图形图像解析程序解析符合以下格式的文件:

a) BMP;

b) GIF;

c) JPEG;

d) PNG;

e) SVG。

7.2.6 文档

移动终端浏览器应通过自身或调用文档解析程序解析符合以下文档格式的文件:

a) XML;

b) 符合 GB/T 44720要求的 UOF文件;

c) 符合 GB/T 33190要求的 OFD文件。

8 浏览

8.1 界面

8.1.1 界面管理

8.1.1.1 适应屏幕

移动终端浏览器屏幕自适应要求如下:

a) 应自适应不同种类和尺寸的屏幕;

b) 应全屏显示,并按用户操作自由切换全屏和非全屏模式;

c) 宜避开有摄像头的挖孔屏或有折叠区域的折叠屏的相关区域显示;

d) 宜适应折叠屏实现多屏及分屏协同操作;

e) 可在具备横屏显示能力的移动终端上自由切换横屏和竖屏浏览。

8.1.1.2 主题管理

移动终端浏览器应提供主题管理:

a) 设置背景颜色;

b) 下载、保存和切换主题;

c) 提供夜间主题模式,对浏览器交互界面的颜色做深色变换。

8.1.2 导航

8.1.2.1 地址栏

移动终端浏览器应提供以下地址栏操作。

a) 地址栏输入包括如下内容。

1) 直接输入:直接输入访问地址,URL最大长度不小于2048字节。

2) 历史输入适配:根据历史输入记录自动匹配输入地址。

3) 书签地址适配:根据书签地址,自动匹配输入地址。

4) 地址推荐:可为用户列出相关地址建议。

b) 地址栏编辑:复制、粘贴、剪切地址栏中的内容。

c) 清除历史:清除地址栏输入历史记录。

8.1.2.2 网页导航

移动终端浏览器应对网页实现以下操作。

a) 打开网页:通过输入 URL,点击超链接或选择书签等形式打开网页。

b) 网页的后退或前进:

1) 后退:访问上一次已经访问过的网页;

2) 前进:后退操作的逆操作。

c) 中止网页:停止读取或继续展现当前网页。

d) 返回主页:能返回到主页。

e) 刷新网页:刷新当前网页。

8.1.3 标签页

8.1.3.1 标签页管理

移动终端浏览器提供标签页管理。

a) 应能新建标签页,并可设置浏览器的默认主页。

b) 应能关闭当前正在浏览标签页。

c) 应能管理多个标签页:

1) 同时打开3个以上标签页;

2) 不同标签页切换显示。

8.1.3.2 页面滚动

浏览页面时,移动终端浏览器应能通过触控或其他输入方式(如快捷键)滚动页面,能快速跳转到页面顶部或页面底端。

8.1.3.3 页面显示
8.1.3.3.1 内容

移动终端浏览器应能显示文字和多媒体文件内容

a) 文字:能按排版格式显示文字块中的文字,格式包括:

1) 文字的字体、字号;

2) 段落内的行距。

b) 多媒体:应识别、展示或播放图形图像、音视频等多媒体文件内容:

1) 对于无法识别的媒体文件,应在相应位置给出提示信息,如显示图形图像和音视频错误占位图等错误样式;

2) 宜调用浏览器指定的视频播放软件播放视频;

3) 宜保存背景图形图像。

8.1.3.3.2 模式

移动终端浏览器宜支持不同显示模式:

a) 阅读模式:展示页面正文内容;

b) 图像浏览模式:对图文混排页面提供图集浏览;

c) 智能拼页:对自动分页内容拼接为单页连续阅读。

8.1.3.4 页面操作
8.1.3.4.1 键盘/触屏输入

移动终端浏览器应接收并显示键盘字符输入内容,响应键盘操作。对于带触屏的移动终端,移动终端浏览器应响应触屏操作:

a) 响应划屏动作,如按预设手势触发前进或后退;

b) 虚拟键盘的弹出/收起与页面窗口自动重排;

c) 使用浏览器自带或用户自定义快捷键快速访问常用网址。

8.1.3.4.2 内容输入

移动终端浏览器在允许输入内容的区域应通过手写或键盘等方式输入,输入内容的条件或限制应包括:

a) 格式类型,如仅允许数字;

b) 最大输入字符数;

c) 输入区域的坐标位置和大小;

d) 使用剪贴板的内容。

8.1.3.4.3 信息提取

移动终端浏览器应能从页面中提取信息:

a) 通过关键字搜索页面文字;

b) 通过复制等方式提取页面中的文字(全部或部分)以及超链接地址;

c) 通过保存文件等方式保存页面中的图形图像等。

8.1.3.4.4 打印

移动终端浏览器宜通过调用接口或浏览器内置菜单实现页面内容打印,且打印动作由用户触发。

8.1.3.4.5 无障碍访问

移动终端浏览器宜按 GB/T 46070通过操作系统或软件自身无障碍访问网页,包括以下内容。

a) 视觉辅助:

1) 自动匹配视频内容对应的字幕,调节字幕大小、颜色和背景透明度;

2) 自定义色彩滤镜,调节适合色盲或色弱用户的亮度、对比度和饱和度;

3) 提供屏幕放大镜,倍数可在2倍~10倍间调节,且跟随手指移动。

b) 听觉辅助:内置语音合成,实时朗读页面文字内容,可自定义语速。

c) 语义辅助:

1) 能识别并解析页面标注的语义信息;

2) 对浏览器界面标签做语义标注;

3) 为导航栏、按钮等设置焦点提示,当元素获取焦点时,通过视觉或听觉反馈给用户。

d) 适老化:可调整字号大小,段落文字的行距不小于1.3倍,且段落间距比行距大1.3倍以上,自适应适用场景和显示效果。

8.1.3.5 内容分享

移动终端浏览器应具备页面内容分享功能:

a) 将书签、页面、图形图像等分享到第三方应用;

b) 在多个移动终端共享页面内容。

8.1.3.6 页面预处理

移动终端浏览器宜支持页面预读和数据缓存

a) 页面预读:

1) 预读内容可包括文字和图形图像等;

2) 按关键字、用户访问偏好或用户访问历史统计等方式设置预读策略。

b) 数据缓存:提供页面及图形图像缓存,并提供手动或定期自动清理缓存数据功能。

8.1.4 搜索

移动终端浏览器宜提供搜索过滤机制,设置关键词规则库,过滤或不主动推荐相关关键词结果。移动终端浏览器宜提供内嵌搜索引擎,并允许用户自由选择或切换:

a) 内嵌搜索引擎不少于3种;

b) 记录并管理搜索历史词条;

c) 提供搜索词补充建议。

8.2 用户数据

8.2.1 书签

8.2.1.1 书签管理

移动终端浏览器应能管理书签。

a) 添加书签:将当前打开的网页地址加入书签或用户 自定义添加书签,书签信息包括标题和 URL。

b) 编辑书签:修改书签信息。

c) 删除书签:删除所选择的书签,并支持去重。

8.2.1.2 书签目录管理

移动终端浏览器应能管理书签目录。

a) 创建目录:用户自定义创建多层级书签目录。

b) 书签移动及排序管理:

1) 将书签移至指定书签目录;

2) 在书签列表中向上或向下移动书签,或将书签移至书签列表第一条或最后一条;

3) 对同一目录下的书签按标题首字母升序或降序排序。

c) 目录导入:导入 HTML、XML等格式的书签目录文件。

d) 目录导出:以文件方式导出浏览器书签。

e) 目录同步:同一浏览器按用户账号同步书签目录。

8.2.2 上传

移动终端浏览器应按操作系统文件管理机制上传本地文件,或调用音视频输入装置上传音视频文件。

8.2.3 下载

8.2.3.1 多任务下载

移动终端浏览器在多任务下载时提供以下能力。

a) 多任务下载:

1) 应同时支持不少于3个下载任务,下载任务数量可调整;

2) 下载任务可后台执行。

b) 宜提供单个任务多线程下载。

c) 宜支持用户指定下载文件处理,如下载文件的本地存储位置,下载文件的指定名称。

8.2.3.2 下载过程管理

移动终端浏览器提供下载过程管理。

a) 暂停下载:应能暂停正在下载的任务。

b) 断点续传:下载文件中断时,宜从下载文件暂停的位置继续下载。

c) 重新下载:宜对任务发起重新下载

d) 删除下载任务:宜能删除选定任务或一次性删除全部任务。

e) 下载状态显示:宜能显示下载文件大小、下载速度和进度。

8.2.3.3 下载后处理

移动终端浏览器对下载后内容处理:

a) 应在下载结束时给出提示,宜支持用户重命名已下载文件;

b) 应能通过自身或调用其他应用程序,打开下载文件和下载文件所在目录。

8.2.4 访问记录

8.2.4.1 管理 Cookie

移动终端浏览器能管理 Cookie:

a) 单个 Cookie最大容量宜不小于4 kB;

b) 单个域名可保存,保存的 Cookie数量宜不少于30个;

c) 当存储的 Cookie容量达到上限时,宜覆盖最早的 Cookie记录;

d) 宜能删除 Cookie。

8.2.4.2 历史记录管理

移动终端浏览器应管理用户浏览历史记录:

a) 保存200个以上历史记录;

b) 删除浏览历史记录;

c) 重新访问历史记录列表中的网页。

8.2.5 用户账号管理

移动终端浏览器能实现用户账号的管理:

a) 宜支持跨终端同步用户配置,如账号、书签和口令等;

b) 用户数据同步过程宜使用加密传输并经用户授权;

c) 宜支持多账号表单密码自动保存与填充,按域名管理并使用用户账号密码。

8.3 配置管理

8.3.1 参数与权限

移动终端浏览器能实现参数设置与权限管理:

a) 应提供恢复默认参数设置;

b) 宜提供录音或人脸识别等权限策略,且“仅在使用时允许”,请求流程应符合移动端操作系统支持的“运行时权限”机制。

8.3.2 网络设置

移动终端浏览器应检查当前网络连接工作状态,选择网络接入点:

a) 使用操作系统选择的网络接入点;

b) 当检测到使用按流量计费的网络且流量较大时,应暂停加载并提示用户,用户可选择继续使用当前网络或切换至非计费网络。

8.3.3 低功耗

移动终端浏览器提供低功耗模式,并进行状态管理;

a) 进入低功耗模式时,应在后台冻结用户态等类型定时器及网络活动;

b) 应响应系统休眠与唤醒广播,保存和恢复关键状态。

9 定制开发

9.1 网页扩展

9.1.1 信息查看

移动终端浏览器应能提供页面属性查看,包括网页 URL、页面内超链接 URL或图形图像 URL等信息。

9.1.2 页面扩展

移动终端浏览器宜支持基于 HTML、CSS和JS的扩展。

9.2 内核定制

移动终端浏览器宜通过内核定制实现能力扩展:

a) 宜支持内核的自定义扩展,如自定义网络代理、网页播放器接管和背景图形图像长按识别保存等;

b) 宜为不同标签页提供独立的资源上下文,隔离不同用户的配置和存储分区;

c) 宜提供网络扩展,如用户自定义 DNS解析策略,自定义网络协议扩展点和显示中文域名等;

d) 内存不足时,宜优化图形图像解码方式,如占位但不显示或延迟解码;

e) 自动恢复网页时,宜保留用户输入状态。

9.3 人工智能增强

9.3.1 部署

移动终端浏览器支持人工智能部署:

a) 宜支持移动终端、远程服务器或混合部署;

b) 远程服务器宜支持加密传输;

c) 宜支持私有化部署,可指定大模型地址、鉴权方式、数据回传策略。

9.3.2 模型接入

移动终端浏览器宜具备接入人工智能模型能力:

a) 宜支持一种或多种模型接入,包括自有模型、第三方大模型 API和客户端模型等;

b) 客户端推理宜优先调用操作系统或浏览器提供的推理 API;

c) 模型切换不影响用户已保存的数据与配置;

d) 宜支持检索增强生成等结合本地或受控外部知识源的接入方式;

e) 宜支持插件形式,调用内置或第三方大模型。

9.3.3 智能交互

移动终端浏览器宜采用人工智能方式辅助交互。

a) 语音识别:支持用户语音输入,并能识别并解析语音输入内容。

b) 自然语言问答:以日常对话形式提问,直接获取答案,无需复杂关键词。

c) 多模态搜索:搜索内容支持文字和图形图像等多种输入形式,如拍照搜题、识别物体等。

d) 人工智能相机:调用系统相机或读取图库,实现扫一扫、文字识别、文件扫描、翻译、物体识别等。

e) 人工智能写作:在合适的输入位置生成点评、短文、社交媒体文案等内容。

f) 文种转换:实现不同文种之间的相互转换。

g) 页面语音播报:根据用户设置实现页面语音播报。

h) 历史对话管理:对话产生的内容自动留存,关闭窗口不丢失,用户可删除历史对话。浏览器页面应按 GB 45438中给出的方法显示添加的人工智能内容标识。

9.3.4 页面智能处理

移动终端浏览器宜支持页面智能处理:

a) 提取网页结构化内容,提供摘要、要点提取和问答等;

b) 网页视频中的字幕提取、要点摘要和章节切分等;

c) 为网页提供结构化导图、大纲、笔记等,并支持导出为 HTML等格式;

d) 支持多语种翻译,宜支持整页翻译和划词翻译;

e) 按照用户个性化需求聚合浏览信息内容,用户可设置聚合的主要内容、板块、信息源或工具入口等信息。

9.3.5 文件智能处理

移动终端浏览器宜实现文件智能处理:

a) 图形图像的识别和编辑;

b) OFD等版式文档的批注、内容提取和辅助编辑;

c) 二维码、条形码的扫描识别与处理。

10 安全

10.1 密码算法

移动终端浏览器能实现下列密码算法:

a) 应实现传输层加密算法,如非对称加密和对称加密;

b) 宜实现后量子加密算法;

c) 宜实现 GB/T 32918(所有部分)规定的SM2椭圆曲线公钥密码算法;

d) 宜实现 GB/T 32905规定的SM3密码杂凑算法;

e) 宜实现 GB/T 32907规定的SM4分组密码算法。

10.2 数字证书

移动终端浏览器对数字证书处理要求如下:

a) 应信任操作系统提供的 DV、OV、EV 等数字证书;

b) 应能识别数字证书;

c) 宜对证书不安全的网站给出拦截并提示。

10.3 数据安全

移动终端浏览器应提供数据安全保护:

a) 加密保存到本地的用户数据;

b) 设置禁用跨站跟踪;

c) 按 GB/T 46071履行数据安全和个人信息保护社会责任。

10.4 网页安全

移动终端浏览器提供网页安全防护:

a) 应提供网页过滤机制,过滤或不主动推荐相关网页结果;

b) 宜对有安全风险的网页设置规则库;

c) 面向未成年人提供的内容过滤应符合 GB/T 44445中的相关规定;

d) 宜提供儿童保护等用户自定义网页过滤或网页访问机制;

e) 当用户访问被过滤网页时,应给出告知提示。

10.5 内核安全

移动终端浏览器应提供内核安全防护:

a) 采用多进程架构,网络、渲染、扩展和 GPU 等进程相互隔离;

b) 采用沙箱机制,限制I/O、网络、进程和系统 API调用权限;

c) 对于外部插件使用沙箱机制限制其能力,并按最小权限原则,授予访问特定设备或 API的权限;

d) 不同类型脚本在不同隔离域运行,不同隔离域的脚本未经授权不相互访问;

e) 提供同源策略,非同源的脚本上下文之间除符合安全策略的受控机制外,不相互访问。

10.6 安全升级

移动终端浏览器:

a) 应对内核进行安全更新,宜公开版本号、上游基线和补丁集合等;

b) 应根据漏洞级别设置漏洞响应机制,漏洞处置最长时间不超过6个月。

参考文献

[1] GB/T 18792 信息技术 文件描述和处理语言 超文本置标语言(HTML)

[2] GB/T 32905 信息安全技术 SM3密码杂凑算法

[3] GB/T 32907 信息安全技术 SM4分组密码算法

[4] GB/T 32918(所有部分) 信息安全技术 SM2椭圆曲线公钥密码算法

[5] GB/T 33475.2 信息技术 高效多媒体编码 第2部分:视频

[6] GB/T 33475.3 信息技术 高效多媒体编码 第3部分:音频

[7] GB/T 38636 信息安全技术 传输层密码协议(TLCP)

[8] GB/T 46070 移动智能终端信息无障碍通用规范

[9] CSS 2.2(W3C) 层叠样式表(https://www.w3.org/TR/CSS22/)

[11] DOM (https://dom.spec.whatwg.org/)

[12] ECMA-262 ECMAScript 语言规范 (https://ecma-international.org/publications-and-standards/standards/ecma-262/)

[13] HTML 4.0.1 超文本置标语言 HTML 4.01 Strict(http://www.w3.org/TR/html4)

[14] HTML 5(https://www.w3.org/TR/2008/WD-html5-20080610/editing.html)

[15] IETF RFC 1945 Hypertext Transfer Protocol-HTTP/1.0

[16] IETF RFC 2246 The TLS Protocol Version 1.0

[17] IETF RFC 2660 The Secure HyperText Transfer Protocol

[18] IETF RFC 2818 HTTP Over TLS

[19] IETF RFC 4287 The Atom Syndication Format

[20] IETF RFC 4346 The Transport Layer Security(TLS)Protocol Version 1.1

[21] IETF RFC 5246 The Transport Layer Security(TLS)Protocol Version 1.2

[22] IETF RFC 6101 The Secure Sockets Layer(SSL)Protocol Version 3.0

[23] IETF RFC 6265 HTTP State Management Mechanism

[24] IETF RFC 7234 Hypertext Transfer Protocol(HTTP/1.1):Caching

[25] IETF RFC 8446 The Transport Layer Security(TLS)Protocol Version 1.3

[26] IETF RFC 9110 HTTP Semantics

[27] IETF RFC 9113 HTTP/2

[28] IETF RFC 9114 HTTP/3

[29] WCSS 1.2(OMA-TS-WCSS-V1_2-20080923-C)

[30] WebSocket协议(https://websocket.org/standards)

[31] WTLS Class I协议

[32] XHTML Basic 1.1(http://www.w3.org/TR/xhtml-basic/)

[33] XHTML Mobile Profile 1.2 (http://www.openmobilealliance.org/tech/DTD/xhtml-

mobile11.dtd)

[34] XML 1.0 and XML Namespaces(http://www.w3.org/TR/REC-xml/)

[35] XMLHTTPREQUEST(AJAX)(http://www.w3.org/TR/XMLHttpRequest/)

资源下载此资源下载价格为5金币立即购买,VIP免费

1.本站大部份文档均属免费,部份收费文档,经过本站分类整理,花了精力和时间,收费文档是为了网站运营成本等费用开支;
2.购买会员:全部免费下载本站资源(或单次下载)即视为对网站的赞助、打赏,非商业交易行为(不认同此观点请勿支付)请慎重考虑;
3.所有收费文档都真实可靠,为了节约成本,文档在网站前台不做预览,如果付费后,与实际文档不符合,都可以加微信号:pdftj888申请退款;
4.付费下载过程中,如果遇到下载问题,都可以加微信号pdftj888解决;
5.手机支付,尽量选择支付宝支付;
6.如图集或者标准不清楚,在本站找不到您需要的规范和图集,希望增加资料等任何问题,可联系微信号:pdftj888解决;

文档天下
  • 本文由 发表于 2026年11月15日 16:06:01
  • 转载请务必保留本文链接:https://www.998pdf.com/83335.html
标准

GBT 35600-2026 文具用品术语及分类

前言 本文件按照 GB/T 1.1—2020《标准化工作导则 第1部分:标准化文件的结构和起草规则》的规定起草。 本文件代替 GB/T 35600—2017《文具用品术语及分类》,与 GB/T 356...
标准

GB/T 36309-2026 公共文化资源分类

前言 本文件按照 GB/T 1.1—2020《标准化工作导则 第1部分:标准化文件的结构和起草规则》的规定起草。 本文件代替 GB/T 36309—2018《公共文化资源分类》,与 GB/T 3630...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: